PSP already capable of emulating 3.01 without updating

After just a few days since the release of Sony's latest PSP firmware update, it has already been cracked and is now being emulated on PSPs with older firmware versions.

There are no news yet regarding the Playstation 1 emulator
compatibility with this method, but even if there is, I doubt Sony will
allow people to purchase and play games on 3.01 PSPs for very long.

It's a never ending battle, instead of what could have been a long
and prosperous relationship. People like to have homebrew software in
their consoles, but they also enjoy great (and fun) games, and right
now, if you buy a PSP, it doesn't deliver much of those two.

From Forever Geek.

Advertisements

Author: Xavier Ashe

Entrepreneur, Infosec Executive, CISSP, CISM, Ironman triathlete, traveler, UU, paleo, father of 8, goyishe, gamer, & geek. http://linkedin.com/in/xavierashe

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s